Skip Standard Navigation Links
CDC Home
Safer, Healthier People
CDC HomeCDC SearchHealth Topics A-Z
   
  WONDER Home FAQ Help Contact Us Search  
 

WONDER Quick Start Guide

This page has pointers for a quick start in using WONDER's data and reporting features.
WONDER how...
  1. Request data from WONDER databases?

  2. Organize a table of my data results?
    (What is a "By-Variable"?)

  3. Make a map of my data results?

  4. Make charts of my data results?

  5. Download my data extract as a file for use in other software?

  6. Find the technical notes and other information for the data in my data request?

  7. What citation is suggested for my data?

  8. Set how many quantiles are used my data analysis, or define my own break-points?

  9. Increase the "time-out" limit for database access, when I request a complex or large query?

  10. Select items from the list box?

  11. Change a "CheckBox?" A "Radio Button?"

  12. Save my tables, charts and maps to my own computer, or paste them into other reports?

  13. Use a Finder Tool to select values?


How do I request data from WONDER databases?

The Request screen has sections to guide you through the making a data request as step-by-step process. However, to get your first taste of how the system works, you might want to simply press any Send button, and execute the default data request. The data results for your query appear on the Table screen. After you get your data results, try the Chart and Map screens. Or export your data to a file (tab-delimited line listing)for download to your computer.

'By-Variables' Select variables that serve as keys (indexes) for organizing your data. See How do I organize my data? for more information.
Note:   To map your data, you must select at least one geographical location as a "By-Variable" for grouping your data, such as Region or State.
Help Click on any button labeled "Help", located to the right hand side of the screen at the top of each section. Each Control's label, such as the "Location" label next to the Location entry box, is linked to the on-line help for that item.
Send Sends your data request to be processed on the CDC WONDER databases. The Send buttons are located on the bottom of the Request page, and also in the upper right corner of each section, for easy access.

Back to Top


How can I organize a table of my data results?
(What is a "By-Variable"?)

On the Request screen, you can select "By-Variables," which serve as keys (indexes) for organizing your data. For example you can select to show the results grouped by Year and by Sex, so that the data results display in a table, summarized (stratified) by the values in the Year and Sex variables. The table's first column is the first By-Variable selection (Year values in the given example), the second column is the second By-Variable selection (Sex values in this example), with a row for each grouping (each combination) of the selected By-Variable values (this example yields a row for each combination of Year and Sex values). These groupings shape the charts and maps you can create for your data. If you choose to export your data results to a file, then you see a line-listing structured by your "By-Variable" choices.


Year Sex Rate
1999 Female 4.62
1999 Male 7.99
2000 Female 4.25
2000 Male 7.37

The data is ordered by the By-Variables as well, when Year is the first By-Variable selection, then the rows are ordered so that the first row contains the least year value. In this example, when the data is limited to 1999-2000, then 1999 values display in the first rows. Categorical values are ordered alphabetically. In this example, when the Sex values are Female and Male, then the Female rows display above the Male rows.

Hints:   

  1. To make a map, you must request data with a geographic location variable, such as Region or State, as a "By-Variable." Then click the Map tab.
  2. You cannot make charts when your data has more than two By-Variables.
  3. You cannot make charts for data grouped by Region and also by State, because the number of states per each region varies.
Back to Top

How do I make a map of my data results?

  1. First, you must send a request for data, and you must select at least one geographical location as a "By-Variable" for grouping your data, such as Region or State.
  2. Next Click on the Map tab near the top of the screen, to go to the Map Options page, where you can set which data items to map, the number of quantiles (or set your own break points) for your data, and control your map's size, color, legends and more.
    -Or-
    To get a quick idea of what your map might look like, just proceed to the the next step with a default map of your data.
  3. Then press any Map button, located along the right side of the screen, to create a map of your data.
  4. Want to save the map to your computer?
    To capture the entire page, with the description, citation, other issues, and (optional) table of data results, open your web browser's File menu, and then select either the Save or Save As option.
    -Or-
    It is simply a web page with image file(s), so you can select the sections you want, and copy and paste the selected material into an e-mail or document.
    -Or-
    You can also simply click your right Mouse button to see options for saving each image.
    Note:   The legend and outlying areas may be separate image files.

Back to Top


How can I make charts of my data results?

  1. First, you must send a request for data. The "By-Variables" you select before sending your data request shape the charts you can create. For example, you can create a histogram plotting changes over time, if you you select a time data item, such as Year, as a By-Variable.
    Note:   Charts can be made with only one or two By-Variables, such as plotting Rate by Region and Disease. Rate is the "measure" distributed "by" Region and Disease.
  2. Next Click on the Chart tab near the top of the screen, to go to the Chart Options page, where you can select which data items to chart and organize your data axis, and select your chart's style,colors, size, labels, and more.
    -Or-
    To get a quick idea of what your chart might look like, just proceed to the the next step with a default chart of your data.
    Hints:
    • Each measure you select creates a chart, so that you can compare side-by-side charts.
    • When you have selected more than one measure, such a Rate and Previous Year Rate, then you can create complex charts by opting to combine the measures on one chart. Both measures are plotted on one chart, for an immediate visual comparison.
  3. Then press any Chart button, located along the right side of the screen, to create a map of your data.
  4. Want to save the chart to your computer?
    To capture the entire page, with the description, citation, other issues, and (optional) table of data results, open your web browser's File menu, and then select either the Save or Save As option.
    -Or-
    It is simply a web page with image file(s), so you can select the sections you want, and copy and paste the selected material into an e-mail or document.
    -Or-
    You can also simply click your right Mouse button to see options for saving each image.

Back to Top


How do I download my data extract as a file for use in other software?

You can download a simple text file, which is a tab-delimited (the columns of data values are separated by Tabs) line-listing of your data results.

  1. First, you must send a request for data. The "By-Variables" you select in your data request define the columns and rows, as well as the detail of your data. See tables for a quick example.
  2. After you have the results of your data request, you can click on the Table tab near the top of the screen, to go to the Table Options page, where you can set whether to show totals and sub-totals, zero value rows, labels on every row and the decimal precision of data items, such as rates.
    Where are the options?   Click on the link that says "Options" or look near the bottom of the page, below the the table of data, and above the data description, citation and other issues, for a box with the table option controls.
  3. Then press the Tab Export button, located at the top of the page, above the data results.
  4. Your web browser then asks you whether to save the file, or to open it now. If you open it now, you can later select your File menu's Save As option to save the file to computer with your preferred folder and filename.
  5. Most analysis software packages can load delimited simple text, when the rows and columns are separated by commas or by tabs. If your software has trouble importing a delimited file, you may wish to remove all titles and descriptive text included in the file above and below the numeric values.
    Note:   More information about importing the data extract into Epi Info and other applications can be found here.
Notes About the data extract file:

Back to Top

How do I find the technical notes and other information for the data in my data request?

Back to Top

What citation is suggested for my data?

Look below the table, chart or map, or at the bottom of your data extract file. The suggested citation for each database is shown in the information that appears below the data results. The data collection's specific technical notes include more information about the data sources for the database.

Back to Top

How do I set how many quantiles are used my data analysis, or define my own break-points?

You can define how many quantiles, and also set your own custom break-points, for maps of your data on the Map Options page.

The quantile setting defines the number of categories or distribution sets used for analysis of your data. The default quantile setting for the mapped data values is quartiles, which distributes your data into four ordered sets. You can choose up to 10 sets for your distribution. You can also define your own custom break-points, which are the range values that define the distributions of your data.

More about quantiles: Each set represents an approximate fraction of the data less than or equal to number of quantiles. The f (fraction) quantile of a dataset is a value with an approximate fraction less than or equal to 1/f of the quantity measured. The sample median, corresponding to f = 0.5, is a measure of the center of a distribution, the middle value of the ordered data. The lower and upper quartiles correspond to f = 0.25 and f = 0.75, respectively. The interquartile range, the difference between the upper and lower quartiles, is a measure of variation. A range of values may satisfy the definition of the quantile distribution, and an interpolated value can be used.

Back to Top

How do I increase the "time-out" limit for database access, when I request a complex or large query?

In the last section of the Request screen, there is a setting labeled "Data Access Timeout." This value specifies the maximum time for the database access to wait for a query to complete. If the data access takes too long to complete, a message notifies you of the problem. Then you can increase the timeout or simplify your request.

Note:   If a request cannot complete with the maximum timeout, contact us and ask for a custom data request for you.

Hint:   Click on the Request tab near the top of the screen, to go to the Request screen.

Back to Top

How do I select items from the list box?

First, look at the box to see if you are able to select more than option.

Multiple-selection list boxes:
If the box shows more than one item, and shows a scroll bar along the right side, then you can usually select more than one item. The highlighted line(s) indicate the selected item(s).

Single-selection list boxes:
If you only see one item at a time in the box, then this list box only allows you to select one item from the list.

Back to Top

How do I change a "CheckBox?" A "Radio Button?"

Back to Top

How do I save my data results to my own computer?

Refer to the help feature for your computer's operating system, and for your specific desktop applications to learn more.

Back to Top

How do I use a Finder Tool to select values?

The Finder Tool helps you look up items in hierarchical code sets. For example, location codes can be grouped into regions, which contain divisions, which contain states, which contain counties. Disease codes may be structured into categories that are organized into various subordinate levels of detail.

  1. Go to the Finder Tool for the variable, the Regular Finder Options will be displayed.
  2. The Finder Tool displays the top level items for the variable you've selected. Underneath this list is a group of buttons for the different actions you can perform.
    • How do I see what which counties are in Alabama?
      Assuming you're looking at a states Finder, click on Alabama and then click the Open button below the box.
      See Selections about how to select items in a list box.
    • How do I make those counties go away again?
      Click on the Alabama and then click the Close button below the box.
    • What if I just want to look up something by name?
      Click on the Search tab at the top of the Finder Tool. When the Search window displays, you can type in up to three words or phrases to search for. The results show up in a list box that has the same controls (actions) as the Hierarchy list box you saw first.
  3. I see an item I want!
    • How do I select it?
      Click on the item(s) you want to select, all items highlighted in that box are used as selections for your request. If your browser has JavaScript enabled, there will be a box labeled Currently selected that shows all selected items in the box regardless of whether they are currently visible.
    • What if I change my mind?
      Just click a highlighted item to un-select it.
  4. I want to select a lot of items and it's awkward.
    • If your browser has JavaScript enabled (most do), click the "Advanced Finder Options" link. That will bring up a version of the Finder Tool that makes it easier to do this.
    • Now you can make selections as usual in the box on the right and click the "Move Items Over" button to move them to the "Selected Items" box. You can accumulate items there, much like a shopping cart, until you have the items you want to include in the request.
For more information about Finder Tools controls, see Finder Tool Help.

Back to Top

What if my question isn't addressed here?

Please also see Frequently Asked Questions for more general information about CDC WONDER.

CDC WONDER is a product of Centers for Disease Control and Prevention. Questions or problems regarding this web site should be directed to cwus@cdc.gov.

Back to Top



This page last reviewed: Wednesday, August 13, 2014
This information is provided as technical reference material. Please contact us at cwus@cdc.gov to request a simple text version of this document.