Skip directly to search Skip directly to A to Z list Skip directly to page options Skip directly to site content

WONDER Data Export Help

Data Export File Description

When you click the Export button, located above the table at the right on the Results tab, then WONDER creates a tab-delimited simple text file of your data request (query) results. Your web browser will prompt you to either open the file or save it to your computer. Please take note of the file name supplied with your query results. The filename is from the Title field on the Request Form tab, or a default name if no title was given. You can type a new title and download location when you save the file. If you open the file, then you can specify a new filename and location using the Save As option on the File menu in your viewer/editor.

In addition to the query results, the WONDER export files contain a summary of your query criteria, any footnotes and "caveat" issues concerning these data, as well as the recommended citation for the data and a link to the data's online documentation. This information is in the left-most "Notes" column, and appears below the data rows. You can quickly locate the this additional information inside the open file by using your search/find feature to locate the section beginning "Query Parameters."

Below are tips for using some commonly available software products. These tools can be used to import your WONDER export data file for further review and analysis on your local computer. No endorsement or preference is intended for use of any commercial or proprietary tools. The Epi Info software is developed by CDC and partners, for more information please see http://wwwn.cdc.gov/epiinfo/.

To assist you in using these instructions, the screen areas names are given to the left of the instructions. Italics indicate the screen areas for user selected options or input. The recommended selection or input is indicated in bold.


Tips for importing WONDER tab-delimited files into Epi Info

If you have Epi Info available, it can be used to view and analyze WONDER export files. For more information, see http://wwwn.cdc.gov/epiinfo/. To ensure the data are properly imported we recommend you do the following:
Starting Epi Info:    Start Epi Info and click the Analyze Data button. Epi Info will open a new window.
Analysis:    In the Analysis Commands tree, select Data Read(Import).
READ:    In the Data Formats drop-down list, select Text (Delimited). From Data Source, click the File Find button and locate your file. Then click the OK button. Epi Info will open your browser or text editor for you to review the file you have selected.
FILESPEC:    In the drop-down list for Field select (tab). For the Text drop-down list select "(quote). Then click the OK button. Once Epi Info returns with your filename and record count in the message window, you are ready to view, analyze your file, or save a copy of the file in Epi Info format.

Tips for importing WONDER tab-delimited files into Microsoft Excel

If you have Microsoft Excel available, it can be used to view and analyze WONDER export files. For the most of the import options in Excel you can leave the default values; however, to ensure the data are properly imported we recommend you do the following:
Starting Excel:    Start Excel and click File on the Toolbar. Scroll down and select Open.
Open:    In the Open window, either type your filename, or locate your file by browsing folders. If you have trouble seeing your WONDER export file, make sure you have selected Text Files(*.txt, *.tsv) in the Files of type: drop-down list. Excel will then start the 3-step Text Import Wizard.
Step 1:    Make sure the Delimited is selected as the option for the Original data type.
Step 2:    Select Tab as the Delimiters option. Also, from the Text qualifier drop-down list, you will need to select ".
Step 3:    Click on a column to highlight it and then select the Text option for the Column data format. You will need to do this for all non-numeric columns, or coded numeric fields such as State FIPS. You can exclude the Notes column of additional information from importing with your data by clicking on the Notes column and then clicking Do not import column (skip). If you exclude the Notes column, please keep a copy of the original text in the Notes column in order to document the data source and issues. Click the Finish button. Excel will display your data in the current worksheet for viewing and analysis.

Tips for importing WONDER tab-delimited files into Microsoft Access

If you have Microsoft Access available, it can be used to view and analyze WONDER export files. For the most of the import options in Access you can leave the default values; however, to ensure the data are properly imported we recommend you do the following:
Starting Access:    Start Access and click File on the Toolbar. Scroll down and select Open.
Open:    In the Open window, either type your filename, or locate your file by browsing folders. If you have trouble seeing your WONDER export file, make sure you have selected All Files(*.*) in the Files of type: drop-down list. Access will then start the multi-step Link Text Wizard. The following tips will assist you in utilizing the wizard.
First Wizard Window:    Make sure Delimited - Characters such as comma or tab separate each field option is selected.
Second Wizard Window:    Tab should be selected for the Choose the delimiter that separates your fields: option. Also be sure to check the First Row Contains Fields Names option. Text Qualifier should be set to ". Click the Finish button. You can Access will link your file and you can begin viewing and analysis.
Third Wizard Window:    Click on the Advanced button at the bottom of the screen to access the Link Specification window. You may choose at this point not to import the Notes column with your data by clicking on the Notes column and then checking Do not import field (skip). If you do not include the Notes, please keep a copy of the original text in order to document your data source and issues.
Link Specification Window:    In the Data Type column clicking on the data type will display a drop-down list of data types. For the "Notes" field select Memo as the data type. For all other non-numeric fields or coded numeric fields such as State FIPS select Text as the data type.

Tips for importing WONDER tab-delimited files into SAS

If you have SAS statistical analysis software available, it can be used to view and analyze WONDER export files. To ensure the data are properly imported we recommend you do the following:
Starting SAS:    Prior to staring SAS, we recommend you use a text editor to review the NOTES at the bottom of the WONDER export file as the instructions below will have you delete the NOTES. Start SAS and click File on the Toolbar. Scroll down and select Import Data. SAS will start the Import Wizard
Import Wizard:    The Import Wizard pops up and prompts you through the following steps.
Select Import Type:    Select Tab Delimited File (*) from the Select a data source from the list below options. Check User-defined formats. Checking user defined formats will let you specific the appropriate parameters for your tab delimited file. Click Next.
Select File:    Enter the name of your WONDER export file or locate the file by clicking the Browse button. Click Next.
Select Library and Member:    Enter the name of your SAS library and member name for your SAS dataset. Click Next.
Transfer to EFI:    Click Finish to start the External File Interface (EFI) facility.
Import List:    Click Options to begin specifying your import parameters.
External File / SAS Mapping:    Select One record per SAS row
Style of Input:    Select List.
Delimiter(s):    Click on right arrow button to access the drop-down list. Un-select BLANK and select TAB.
Variable Creation:    Select Automatic (variable names in 1st row) and click the OK button.
Import List:    On this screen you will define the formats appropriate for the data fields. In addition we recommend you delete the Notes column from your data. The Notes column cannot be used for analysis and will cause your SAS dataset to be very large. If you delete these notes from the SAS data set, please keep a copy of the original text of the Notes column in order to document the data source and issues. To delete the Notes column, in the To frame of the window, click on the Notes column then click on the Delete button at the bottom of the window. To set columns to the appropriate formats, click on the column, then at the bottom of the window select Character or Numeric. We suggest you set all non-numeric columns as well as numeric code columns such as State FIPS to character. Next you may select the appropriate size of the variable field.
File menu's Save:    Click File on the Toolbar. Scroll down and select Save. You can now view and analyze your import dataset.



This page last reviewed: Tuesday, January 05, 2016
This information is provided as technical reference material. Please contact us at cwus@cdc.gov to request a simple text version of this document.
TOP